Black seams on meshes in UE4


#1

I am using the cemetery environment assets in UE4, but some of the assets are showing ugly black edges (circled in red in image). Others are showing up correctly (circled in blue in image). When I build lighting, the UE4 editor outputs the following errors for the affected assets:

“Object has overlapping UVs”
“Lightmap UV are overlapping by 1.3%. Please adjust content - enable Error Coloring to visualize.”

Has anyone tried using these assets in UE4 and encountered the same issue? If so, any advice on how to fix it would be appreciated.


#2

Hey @mugwurt !
Have you tried this approach ?


#3

Hi Matt. Thanks for responding. I have the Generate UVs flag set, and have changed the UV Channel to the new UVs. I also tried converting the mesh to a Blueprint. But still getting the same results.

The really odd thing is the same mesh (fence_element_1) has the black edges in some instances and in others shows up fine. I added an image to show an example. It is very strange.


#4

Update… I was able to fix the problem on the ground meshes (stone_path and stone_circle) by turning off “Cast Shadows” in the mesh properties in UE4 editor. I can’t get away with that on the fence sections as it would look strange if they were not casting shadows.


#5

Hi @mugwurt,

Here’s the updated video (from the one @matt posted above) https://www.youtube.com/watch?v=Hba__6ok-3M that should sort all the issues, let us know how you go.

Cheers