Issue with exported model


#1

Hello!

While tinkering around to see if I can brainstorm up some ideas for the game jam, I ran into a slight issue. When modifying a model in Maya LT 2016, whenever I export the model, I receive no errors, however when I import the new file into Unity, there is no mesh data in the file. There is a bone hierarchy, but nothing to render/no mesh data. Re-importing the file back into Maya has nothing inside of it. I have made sure all geometry export options are enabled.

Has anyone else ran into issues like this before? I could use some pointers to help me get started in grinding out game ideas. Thanks!


#2

Hey Renokun! I don’t really have experience with maya LT, but how did you export your model? Maybe you’re an advanced user and my advice sounds really dumb… Did you use export selected or export all? Because it can be confusing that one needs to select mesh and bones to get them exported in the one file. Best to select everything via the outliner, not the view port.


#3

It turns out, one of the export options was causing the issue. Selecting no options and then slowly enabling just the ones I thought were needed worked for me. Weird, but glad I fixed it! Thanks!